February 2017

What’s New · Google Chrome Security Requirements

In January, the security policies for Google Chrome changed. Users now receive an alert that websites are not secure if the site does not meet Google’s new HTTPS requirements. Customers have encountered the alert notification below when accessing their library account via Chrome.

As part of our confidentiality of library records and online security policies, the Library assures customers their information is safe, and nothing has changed with our website’s security software. In addition, fine payments are processed through PayPal, which does meet requirements. We are in the process of upgrading our technology infrastructure to meet Chrome's security requirements. In the interim, we suggest that customers use one of the following approaches:

  • Use Firefox or Internet Explorer to work with their accounts.
  • Bypass the Chrome warning, by clicking the "advanced" button, then clicking "Proceed to classic.cincinnatilibrary.org." Please note, users many need to follow these steps a couple of times before they are redirected to the catalog.
  • Use the Library's app to work with their accounts.
Chrome error