INTRODUCTION
If you took our Excel for Beginners, Part I class you should at this point have a good understanding of the basics of Microsoft Excel 2010. You should know common operations such as navigating the ribbon tabs, moving around in Excel, entering data, basic formulas, and simple formatting. This lesson will cover more advanced topics in the world of spreadsheets, and focus on more specific features including:

- Inserting content (charts, tables, borders, headers & footers)
- Manipulating columns & rows (hiding, freezing, sorting, filtering)
- Stats: AVG, MAX, MIN, & MEDIAN
- Using Paste Special
- Printing (print margins and printing a selected area)

SECTION I: INSERTING CONTENT
Because of the nature of the content of Excel worksheets (typically filled with lots of numbers) they can be visually unappealing or even difficult for people not familiar with Excel to understand. Adding content such as charts/graphs and tables creates a more visually stimulating (and hopefully easier to understand) spreadsheet. Inserted content is also useful for displaying data in ways that makes it easier to sort and filter (we will discuss that more later). Before you begin, make sure you are on the sheet labeled Charts in the Excel Part II Student Workbook.

Charts
A simple chart in Excel can say more than a sheet full of numbers. As you will see, creating a chart is very easy. To create a line chart, execute the following steps: Select the range A2:F8. On the Insert tab, in the Charts group, choose Column, 2D Column, and then Clustered Column. The chart appears on your worksheet – simple, right?

Changing Chart Type
You can easily change to a different type of chart at any time. Start by selecting the chart. On the Insert tab, in the Charts group, choose Bar, 2D Bar, and select Clustered Bar.
Switching Rows/Columns
You can also flip flop the rows and columns in a chart. For example, if you want the expenses, displayed on the vertical axis, to be displayed on the horizontal axis instead, a few simple steps can make that happen. Start by selecting the chart. The Chart Tools tab becomes accessible. On the Design tab, click Switch Row/Column. The same information is displayed, but now it is grouped by expense rather than by month.

Chart Title
Most charts will need a title to identify what they are displaying. To add a chart title, start by selecting the chart. The Chart Tools tab becomes accessible. On the Layout tab, click Chart Title, Above Chart. Enter a title; for example, Budget.
Tables
You can create a table in Excel to help you manage and analyze related data. The purpose of a table is not so much to calculate new values but rather to store lots of information in a consistent manner, making it easier to format, sort, and filter data. Before you begin, make sure you are on the sheet labeled Tables in the Excel Part II Student Workbook.

To create a new table, normally you would click the blank cell where you want to start the new table and then enter the column headings (such as Rent, Car, Phone, Food, Other Bills) in separate cells within the same row. The column headings should appear in a single row without any blank cells between the entries. You would then enter the first row of data immediately below the column headings; lucky for you, we have already filled in the column headings and data to save time. These entries constitute the first row, or record, of the table.

Select the cells you will be working with (in this case select the range A2:F15). Off of the Insert tab, in the Tables group, select Tables. The Create Table dialog box appears, listing the address of the table in the Where Is the Data for Your Table text box. Click the My Table Has Headers check box if it is not already selected (these headers are the column headings we already put in). Select OK. Excel inserts and formats the new table and adds filter arrows (drop-down buttons) to each of the field names in the top row.

Tip: Another way to insert a table is to start on the Home tab, navigate to the Styles group, and click the Format as Table button and then select a table style of your choice in the gallery that appears. Use this method if you want to apply a different table style as you create a table.

If you want to convert an existing Excel table back to a normal range of cells, select any cell in the table. The Table Tools tab becomes accessible. Click the Convert to Range button. All data and formatting will be preserved.
A pivot table is a special type of summary table that’s unique to Excel. Pivot tables are great for summarizing values in a table because they do their magic without making you create formulas to perform the calculations. Pivot tables also let you play around with the arrangement of the summarized data. It’s this capability of changing the arrangement of the summarized data on the fly simply by rotating row and column headings that gives the pivot table its name.

To begin, open the worksheet that contains the table you want summarized by pivot table and select any cell in the table (in our case, we will just use the Tables worksheet we have been working on already). Note: if you were using your own table, it’s crucial to ensure that the table has no blank rows or columns and that each column has a header. Off the Insert tab, in the Tables group, choose PivotTable. Be sure to click the top portion of the button; if you click the arrow, be sure to choose PivotTable in the drop-down menu. Excel opens the Create PivotTable dialog box and selects all the table data, as indicated by a marquee around the cell range.

If necessary, adjust the range in the Table/Range text box under the Select a Table or Range option button.

Tip: If the data source for your pivot table is an external database table created with a separate program, such as Access, click the Use an External Data Source option button, click the Choose Connection button, and then click the name of the connection in the Existing Connections dialog box.

Select the location for the pivot table. By default, Excel builds the pivot table on a new worksheet it adds to the workbook, which is fine for our purposes. If you want the pivot table to appear on the same worksheet, click the Existing Worksheet option button and then indicate the location of the first cell of the new table in the Location text box. Click OK.

Excel adds a blank grid for the new pivot table and displays a PivotTable Field List task pane on the right side of the worksheet area. The PivotTable Field List task pane is divided into two areas: the Choose Fields to Add to Report list box with the names of all the fields in the source data for the pivot table and an area divided into four drop zones (Report Filter, Column Labels, Row Labels, and Values) at the bottom.

To complete the pivot table, assign the fields in the PivotTable Field List task pane to the various parts of the table. You do this by dragging a field name from the Choose Fields to Add to Report list box and dropping it in the drop zones.
The four drop zones to choose from are:

**Report Filter**: This area contains the fields that enable you to page through the data summaries shown in the actual pivot table by filtering out sets of data — they act as the filters for the report. So, for example, if you designate the Month Field from a table as a Report Filter, you can display data summaries in the pivot table for individual months or for all months represented in the table.

**Column Labels**: This area contains the fields that determine the arrangement of data shown in the columns of the pivot table.

**Row Labels**: This area contains the fields that determine the arrangement of data shown in the rows of the pivot table.

**Values**: This area contains the fields that determine which data are presented in the cells of the pivot table — they are the values that are summarized in its last column (totaled by default).

Continue to manipulate the pivot table as needed until the desired results appear. This may take some playing around!

As soon as you create a new pivot table (or select the cell of an existing table in a worksheet), Excel displays the PivotTable Tools tab on the ribbon. The Options tab under PivotTable Tools has many groups to choose from, including the Show/Hide group that contains the following useful command buttons:

- **Field List** to hide and redisplay the PivotTable Field List task pane on the right side of the Worksheet area.

- **+/- Buttons** to hide and redisplay the expand (+) and collapse (-) buttons in front of particular Column Fields or Row Fields that enable you to temporarily remove and then redisplay their particular summarized values in the pivot table.

- **Field Headers** to hide and redisplay the fields assigned to the Column Labels and Row Labels in the pivot table.
Borders
All this table talk might have your head spinning at this point, so let’s talk about something much easier — borders. You can add borders to individual cells to emphasize or define sections of a worksheet or table. Note: Don’t confuse the borders that you add to accent a particular cell selection with the gridlines normally used to define cell borders in the worksheet — borders that you add are printed whether or not you print the worksheet gridlines. You can remove the display of gridlines by going to the Page Layout tab, the Gridlines group, and clearing the View check box.

To add a border, start by going to the worksheet labeled Charts. Select the cells you want to format, in this case A1:F15.

From the Home tab, look for the Cells group, click Format, choose Format Cells, and select the Borders tab to add borders of varying styles and colors to any or all sides of the cell selection.

When selecting an option on the Borders drop-down menu, there are a few things to keep in mind. To have Excel draw borders only around the outside edges of the entire cell selection (in other words, following the path of the expanded cell cursor), click the Outside Borders or the Thick Box Border option. If you want borderlines to appear around all four edges of each cell you’ve selected, select the All Borders option. You can also change the style or color of borders you apply to a cell selection.

To remove borders in a worksheet, select the cell or cells that presently contain them and then click None as your option in the Borders button’s drop-down menu.
Headers & Footers

Headers and footers typically appear on every page of a report. A header is printed in the top margin and a footer is printed in the bottom margin. Headers and footers are often used to identify the document and to display the page numbers and the date and time of printing. Unless you specify otherwise, Excel does not automatically add either a header or footer to a new workbook.

To add a header or footer, start by selecting Insert on the ribbon tab and under the Text group select Header & Footer.

The Design - Header & Footer Tools tab will now be active. Here you will see a variety of different things you can insert into your headers and footers – Page Numbers, Number of Pages, Current Date, Current Time, and so forth. You can also customize your headers and footers by simply typing in the text you want to appear.

Tip: You will notice that when adding a header of footer, the way Excel displays your worksheet changes. The worksheet is now being displayed in the Page Layout view. You can change this by going to the View tab and selecting Normal under the Workbook Views group. You won't see the added header or footer in Normal view, but it's there when you preview or print the worksheet.

If, after selecting some stock header or footer info, you decide that you no longer need either the header or footer printed in your report, you can remove it. Simply click the (None) option at the top of the Header button's or Footer button's drop-down menus.

Use the Go to Header and Go to Footer buttons in the Navigation group of the Design tab to quickly jump between the header and footer of the worksheet. Remember that the Design tab appears only after you've clicked inside the header or footer area.
SECTION II: MANIPULATING COLUMNS & ROWS

Columns (A, B, C, D, etc.) and rows (1, 2, 3, 4, etc.) in Excel form the basis for how all data is displayed. An important skill to learn, however, is how to manipulate those columns and rows in a variety of ways. This is especially important when dealing with large amounts of data – by the time you get down to cell AA155 the columns or rows that you started way back at A1 may be a distant memory. Luckily, there are a few tricks make your spreadsheets carry data further.

Hiding/Showing Columns & Rows

You can hide and unhide rows or columns in Excel when you don’t want part of the worksheet to be visible or when you don’t want certain data (such as salary information) to appear in printed reports — hidden rows and columns do not print.

First, navigate to the “Hiding & Freezing” worksheet. Select the column or row headings you want to hide — for our purposes this will be B2:F2. Press the Ctrl key while selecting multiple rows or columns. Tip: When it comes time to unhide rows or columns, select the rows or columns both before and after the hidden rows or columns. From the Home ribbon tab, look for the Cells group and select Format. Under the Visibility section of the resulting Format drop-down menu you want to choose the Hide & Unhide option. In our case, we want to select Hide Rows.

When you hide columns or rows, the associated column letters or row numbers disappear from the worksheet frame. So in our example, row 2 (and all of the data in it) is now hidden.

To unhide your columns/rows, do the same process as described above only select “unhide” as your final option.

Freezing Panes & Rows

The Freeze Panes command in Excel allows you to freeze portions of a worksheet, typically column and row headings, so that you can view distant parts of the worksheet while the headings remain in place. Freezing panes only affects the current worksheet. If you want to freeze other worksheets, you must select them individually and freeze them. We will stay on the Hiding & Freezing worksheet for this exercise.

The first step is to position the cell cursor based on what you want to freeze. For columns, you want to select the column to the right of the columns you want to freeze. For example, you could click any cell in column B to freeze column A. For rows, select the row below the rows you want to freeze. For example, click any cell in row 4 to freeze row 3. If you want to get really fancy and freeze both columns and rows, click the cell below the rows and to the right of the columns you want to freeze — essentially, the first cell that isn't frozen. For example, click cell B2 to freeze both column A and row 1. Cells above and to the left of the current cell will be frozen.
Select cell A3. Off the View ribbon tab, in the Windows group, select Freeze Panes and then Freeze Panes again.

A thin black line separates the sections. As you scroll down, notice that the column headings (rent, car, phone, etc.) remain fixed no matter how far you scroll down.

If you decide you no longer want the panes frozen, you can simply go back to the View ribbon tab, under the Windows group, and select Freeze Panes and then Unfreeze Panes.

Tip: You can also click the Freeze Top Row or Freeze First Column command in the Freeze Panes drop-down menu to freeze just the top row or first column in the worksheet, without regard to the position of the cell cursor in the worksheet.

Custom Sort/Filter
If your Excel worksheet has become quite large, using the Sort dialog box to sort on multiple columns can make it easier to find the data you need. The Sort dialog box lets you tell Excel what column to sort on next if two cells in the main sort column contain the same value or data. Although the most common sort is by rows, you can also sort by columns.
Select or click in the list of data you want to sort. For our purposes, we want cells A2:F14. Under the Data ribbon tab, look for the Sort & Filter group and choose Sort. In the Sort dialog box, click the Options button, choose Sort Top to Bottom, and click OK. If your data includes column headings, make sure the My Data Has Headers option is checked (Excel usually detects the correct setting automatically).

From the Sort By drop-down list, select the Food column. From the Sort On drop-down list, choose Values. Notice that you also can perform the sort on Cell Color, Font Color, or Cell Icon; typically you will perform a sort based on values (rather than formatting). From the Order drop-down list, select Largest to Smallest. Note: the options that appear in this list change based on the contents of the sort column (text, numeric data, or dates).

Click the Add Level button. Additional drop-down list boxes appear for the secondary sort column. This is the column Excel will sort by if two or more items are identical in the first Sort By option. We will choose to sort by Other Bills. After you specify the options for the secondary sort column, you can add more sort columns (if needed). Use the Move Up and Move Down buttons if you decide to change the order of the sort columns.

Once you have chosen all of your sort options, click OK. The dialog box closes and Excel performs the sort process.
SECT III: STATS: AVERAGE, MAX, MINIMUM, & MEDIAN
Excel Statistical functions — including AVERAGE, MAX, MIN, and MEDIAN — are found under the Formulas tab, in the Function Library group, under the heading AutoSum. Excel includes one of the most complete sets of statistical functions available outside a dedicated statistics software program. This is powerful stuff!

The AVERAGE, MAX (for maximum), and MIN (for minimum) functions are the most commonly used of the statistical functions because they are of use to both the average number cruncher as well as the dedicated statistician. All three functions follow the same syntax as the good old SUM function that we learned about in Excel for Beginners, Part I. Let’s begin my moving to the Stats worksheet and selecting cells E3:E14 (the food column).

Average
The AVERAGE function computes the arithmetic mean of the values in this range by summing them and then dividing them by the number of values in the range. With the E3:E14 range selected, navigate to the Average option under the AutoSum and click it. The formula that should appear in the formula bar is =AVERAGE(E3:E14). By computing the Average amount of money spent on food over 12 months, we come to a final number of $107.92.

With the same cells selected, try the MAX and MIN formulas off the AutoSum button. The MEDIAN function isn’t one of the preset options, but you can still get to it by selecting More Functions and then typing in MEDIAN as a search.

The MEDIAN function computes the value that is in the middle of the range of values; that is, the one where half the values are greater and half are less. This is the reason that the median monthly food expense differs from the average monthly food expense.
SECTION IV: USING PASTE SPECIAL
Excel normally copies all the information in the range of cells you select when you paste the data. However, you can use the Paste Special command to specify other options, such as pasting only the cell contents (without the formatting) or only the formatting (without the cell contents). Let’s start by highlighting the range A1:F15 and selecting Copy. To paste particular parts of a cell selection, click the Paste button arrow on the Home tab. Then, click Paste Special on its drop-down menu to open the Paste Special dialog box.

You can specify which parts of the current cell selection to use by selecting the appropriate Paste Special options:

- **All** to paste all the stuff in the cell selection (formulas, formatting, you name it). This is what happens when you paste normally.
- **Formulas** to paste all the text, numbers, and formulas in the current cell selection without their formatting.
- **Values** to convert formulas in the current cell selection to their calculated values.
- **Formats** to paste only the formatting from the current cell selection, without the cell entries.
- **Comments** to paste only the notes that you attach to their cells (kinda like electronic self-stick notes).
- **Validation** to paste only the data validation rules into the cell range that you set up with the Data Validation command.
- **All Using Source Theme** to paste all the information plus the cell styles applied to the cells.
- **All Except Borders** to paste all the stuff in the cell selection without copying any borders you use there.
- **Column Widths** to apply the column widths of the cells copied to the Clipboard to the columns where the cells are pasted.
- **Formulas and Number Formats** to include the number formats assigned to the pasted values and formulas.
- **Values and Number Formats** to convert formulas to their calculated values and include the number formats you assigned to all the copied or cut values.
- **All Merging Conditional Formats** to paste conditional formatting into the cell range.
When you paste, you can also perform some simple math calculations based on the value(s) in the copied or cut cell(s) and the value in the target cell(s):

- **None**: Excel performs no operation between the data entries you cut or copy to the Clipboard and the data entries in the cell range where you paste. This is the default setting.
- **Add**: Excel adds the values you cut or copy to the Clipboard to the values in the cell range where you paste.
- **Subtract**: Excel subtracts the values you cut or copy to the Clipboard from the values in the cell range where you paste.
- **Multiply**: Excel multiplies the values you cut or copy to the Clipboard by the values in the cell range where you paste.
- **Divide**: Excel divides the values you cut or copy to the Clipboard by the values in the cell range where you paste.

Finally, at the bottom of the Paste Special dialog box, you have a few other options:

- **Skip Blanks**: Select this check box when you want Excel to paste only from the cells that aren’t empty.
- **Transpose**: Select this check box when you want Excel to change the orientation of the pasted entries. For example, if the original cells’ entries run down the rows of a single column of the worksheet, the transposed pasted entries will run across the columns of a single row.
- **Paste Link**: Click this button when you want to establish a link between the copies you’re pasting and the original entries. That way, changes to the original cells automatically update in the pasted copies.

**SECTION V: PRINTING**

**Print Margins**

*Print margins* indicate how much white space Excel places between the worksheet data and the edge of the page. The *Normal* margin settings that Excel applies to a new workbook have top and bottom margins of 0.75 inches and left and right margins of 0.7 inches. In addition to the Normal margin settings, Excel enables you to select *Wide* or *Narrow* margins. Wide margins have a 1-inch top, bottom, left, and right margin and 0.5 inches separating the header and footer from the top and bottom margins. Narrow margins have top and bottom margins of 0.75 inches, and left and right margins of 0.25 inches with 0.3 inches separating the header and footer from the top and bottom margins. You also can specify margins for the header and footer and center your worksheet horizontally or vertically on the page to improve the appearance of a printed report. To explore options for Margins, go to the *Page Layout* ribbon tab, look for the *Page Setup* group, and click on *Margins*.

You also can customize the margins of a report. To get more columns on a page, try reducing the left and right margins. To get more rows on a page, try reducing the top and bottom margins.

You can click the *Print Preview* button in the *Page Setup* dialog box at any time to see how the changes you make affect the preview of your report.
Excel for Beginners, Part II

Print Selected Area

The Print panel in Excel Backstage view includes commands that allow you to specify which parts of a workbook you want to print. To access backstage view, click the File tab and choose Print (or press Ctrl+P). You also can specify a print area by going to the Page Layout tab, looking for the Page Setup group, and selecting Print Area.

You can specify print areas in the Settings section of the Print Panel in Excel's Backstage view. To change what part of the worksheet is printed in the report, select an option in the Print Active Sheets button's drop-down menu — you can choose from the following options:

- Print Active Sheets: Excel prints all the information in active worksheets in your workbook. Normally, this means printing just the data in the current worksheet. To print additional worksheets in the workbook, hold down the Ctrl key while you click the sheets' tabs.
- Print Entire Workbook: Select this option to have Excel print all the data in each of the worksheets in your workbook.
- Print Selection: Select this option to have Excel print just the cells that are currently selected in your workbook. (Remember to select these cells before opening the Print panel and choosing this printing option.)

Depending on what is selected in the worksheet when you display the Print panel, you may see additional options in this menu, including Print Selected Table or Print Selected Chart. Choose the desired option based on what you want to print.

Select Ignore Print Area at the bottom of the Print Active Sheets button's menu when you want one of the other print options (Print Active Sheets, Print Entire Workbook, or Print Selection) that you selected to be used in the printing rather than the print area you previously defined. You can also clear a print area that you set previously by going to the Page Layout tab, looking for the Page Setup group, selecting Print Area and finally Clear Print Area off the drop down menu.

Other options in the Settings area that affect what you print include the following:

- Pages: At times, you may need to print only a page or range of pages. To print a single page, enter its page number in both text boxes or select these page numbers with the spinner buttons. To print a range of pages, put the first page number in the first text box and the last page number in the second text box.
- Print One Sided: If your printer is capable of double-sided printing, you can choose one of the Print on Both Sides settings from the Print One Sided drop-down menu.
- Collated: When you collate pages, you simply make separate stacks of each complete report, rather than print all copies of page one, and then all copies of page two, and so on. To have Excel collate each copy of the report, ensure that Collated is selected in this menu.
SECTION VI: ADDITIONAL RESOURCES

The TechCenter at the Main Branch of the Public Library of Cincinnati & Hamilton County hosts over two dozen technology related classes each month. Ask your instructor today for a calendar of upcoming events or visit our website at www.cincinnatilibrary.org/programs/ for a complete list of all Library events.

If you are liked our Excel for Beginners, Part II class, you may also find these related classes of interest:

- PowerPoint for Beginners
- Word Processing for Beginners, Part II

Feel free to ask for a copy of any class handout at the Technology Center desk or talk to your instructor today.

Online

The Public Library of Cincinnati & Hamilton County offers a variety of databases to all card holders which provide excellent learning opportunities on a variety of topics, including computers and technology.


Universal Class offers more than 500 classes on many topics. These classes are instructed by real teachers who guide your learning and provide feedback on your work. Learn about Microsoft Office, Web Design, Computer Basics, Business Applications, and more! Free with your library card. From http://www.cincinnatilibrary.org, click on Research & Homework > Research Databases > Education > Universal Class.